[ABANDONED] J-Scope issues

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] J-Scope issues

    Dear Segger team,

    for evaluation purposes I installed J-Scope V5.10d and tried it out with some example code running on an ARM Cortex-M7 controller.
    I think J-Scope is a really powerful tool for debug and qualification purposes, but I found also some inconveniences. Maybe I used it incorrectly, but maybe it is a property of the tool which is worth to be improved.

    1) I have an array of floating point numbers. These are displayed correcly.
    a) If I reload the project after a restart of J-Scope, it claims that "the selected symbol could not be found in the application file". This message is shown for all elements in the array I had added.
    b) If I export the data to a CSV file, the floats are not exported correctly. It seems that the binary pattern is reinterpreted as integer number.

    2) After I have added new variables to the application and the ELF file has changed, it is not recognized by J-Scope. (Maybe caused by the first issue?)
    a) The addresses of already added variables do not change accordingly.
    b) The new variables do not appear in the symbol list.

    3) In the J-Scope XML file there are absoulte paths to the source files of the variables stored. This is not handy if the project should be shared among different people with different project locations on their hard disks.
    When I changed the absolute path to a relative paths (in relation to the ELF file / in relation to the jscope file), also the following message appears after reload: "The selected symbol could not be found in the application file."
    A relativ location of the ELF file is accepted.

    4) When I use J-Scope in parallel with my CrossWorks IDE, sometimes a message appears saying that the J-Link firmware needs to be updated. Then an firmware update is performed (always to the version which should have been installed before).
    This is probably not intended...

    5) The "Legend" is not resizable and variable names are truncated after 9 characters. This is problematic if the variable names start with the same letters.

    6) If the target controller is not specified when the project is initially created, J-Scope will always ask for the controller when I want to connect to the target. So, it gets not stored to the jscope file.

    Can you confirm these issues?

    Thanks in advance.
  • Hello Michael,

    could you please try the current beta version v6.11m?
    This version has lots of improvements and should solve at least some issues.

    The request for a firmware update should not happen. But this is more an issue with the J-Link software. J-Scope itself does not care about firmware updates.
    Are you using the latest release of the J-Link software (v6.52)?

    Best regards
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.
  • Hi Arne,

    today, I found the time to evaluate the beta version 6.11m of J-Scope.
    My investigations showed some differences related to version 5.10d. (Compare the above mentioned items.)

    1) OK, the problem with the floating pointer numbers is solved. I also could successfully import the CSV file in Excel after changing the decimal delimiter from comma to dot (File => Options => Extended).
    2) I need to reopen the jscope file so that the ELF file is parsed again. Then I can add new variables. Poorly, if the memory location of any variable has changed, J-Scope asks for every changed variable / memory position if the information should be updated. (There is no check box to excercise this for all variables). This may be annoying if you have a lot of variables.
    3) I could not figure out, how to use relative paths to the application (ELF) and source files. Assumed that I want to share this project by the help of a version control system or put it into a zip file, the absoulte paths may change on another PC. The absolute paths would need to be updated in the XML file accordingly. Is there an option or a placeholder to use relative paths? (The most intentional way would be, that J-Scope stores relative paths by default.)
    4) OK. I did not recognize any unneeded firmware updates of the conneceted J-Link.
    5) The legend is still not resizable. (This is a minor issue.)
    6) Unchanged. If the device was not specified in the initial project setup, J-Scope keeps on asking everytime for the target device when I start the recording.
    7) New issue: After I inserted some variables to the project, the Y resolution of some variables changed for some reason to 2000M/div and for the float numbers an average of "-1.#R" is displayed. I have not called "Y resolution up" for the signals and have not the hotkey + for this command. See attached picture.

    So, I think v6.11m is better than v5.10d. (So, why it is still refered to as 'beta' version?)

    I think that J-Scope is a nice tool. But issue 3 makes it hard to use it in a professional surrounding. Please can you ask if there are solutions available or planned for future revisions?

    Best regards,
    • 2019-10-17_J-Scope V6.11m_strange_values_and_scaling.png

      19.25 kB, 1,361×142, viewed 248 times

    The post was edited 2 times, last by scotty ().