[SOLVED] J-Link: VTREF has to be powered on at each start

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Link: VTREF has to be powered on at each start


    I just received a new "Segger J-link Base"
    In JlinkExe, I entered "Power On -perm" command that allow to have VTref=3V and power on our device
    But I have to enter this command each time I plug the Jlink on my computer, otherwise VTref=0
    I was expecting the -perm option to get rid of that (ie I have only to do it once), but I guess there is another command?

    Thanks for your support
  • Hello Francois,

    Thank you for your inquiry.
    The correct command is "power on perm" without the "-".
    Then it should work as expected.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.