J-Link RTT Viewer Hangs

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • J-Link RTT Viewer Hangs

      I am able to debug and output to the J-link RTT Viewer(V6.44e) and when I stop debugging or sometimes randomly, the Viewer will display the message
      "Warning: IAC character followed by invalid character(nonhexadecimal)"
      and the Viewer freezes and therefore would have to restart it
      I dont know what is causing this issue and when it really started. I previously did not have this issue.
      I am using Nordic SDK 15 and softdevice s132 and Keil V5.24.2.0
      your time, effort, and help will be greatly appreciated.
    • I think it means that it is receiving a non-ascii character in the stream - or interpreting it that way. I am using 6.50b and don't seem to see that issue - but i do have issues with attempting to use vt100 colour codes with rtt viewer showing
      WARNING: ANSI CSI SGR parameter 39 not supported.
      when trying to clear the colour formatting - i probably need to use the RTT specific defines, but it works fine for other terminals
    • Hello,

      Could you please give the most recent version of the J-Link RTT Viewer (V6.51e) a try and tell me if the problem still occurs for you?

      For text formatting, the RTT Viewer is made to work with the RTT_CTRL defines as they are defined in the SEGGER_RTT.h.
      Similarly, we suggest to use the RTT_CTRL_CLEAR define when clearing the terminal.
      Do you have a source/ examples for terminal applications using ANSI CSI SGR parameter 39 for clearing the screen?
      Best regards,
    • whazin wrote:


      I installed 6.52b and now I am getting the error message

      ERROR: <All Terminals>: Terminal change character (IAC) followed by invalid character (non-hexadecimal).

      it does not freeze like it did before but I am nt sending crazy characters and this used to work. please help!

      I am using RTT-Viewer together with the RTT-Subset of the SystemView package and a ADSP-CM40x Microcontroller from Analog Devices:
      SEGGER_RTT_TerminalOut( 0, RTT_CTRL_RESET );
      SEGGER_RTT_TerminalOut( 0, outMessage );

      I have similar problems with the RTT-Viewer: The same ERROR Message occurs at my side two times.

      And i have noticed a change at the RTT-Terminal Window (RTT-Viewer 6.52b vs. earlier 6.40): To start at a next/new line sending a "\r" was sufficent, now it requires "\r\n".
      Is this change intentional ?

      ---- Solved ----
      I have moved SEGGER_RTT_TerminalOut( 0, RTT_CTRL_RESET ) to the end of 'other-formatted' messages (=Workaround for sometimes showing ]0 at the Terminal output)
      And the ERROR above was generated due to disrupted task stack memory caused by a buffer-overrun of other code.

      The post was edited 1 time, last by KeyPi: Solved ().