[SOLVED] "Mass erase done!" repeats forever in Commander

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] "Mass erase done!" repeats forever in Commander

    I'm trying to program a custom SAMD51G18A board over SWD using a Segger J-link EDU Mini. In Atmel Studio 7 > Tools > Device Programming I keep getting this error message:

    Timed out in cmd Device:startSessionUnable to enter programming mode. Verify device selection,interface settings, target power, security bit, and connections to the target device.
    Using J-Link Commander gives me the following:"Mass erase done" repeats until I quit the program.

    My schematic:

    I've verified that the j-link isn't broken by using it to program an adafruit feather board.

    I've probed all of the MCU pins, and power and ground appears to be correctly connected. The reset pin is left unconnected. 3v3 pins have decoupling parallel .1uF and .001uF caps.

    This is my first time making my own pcb and it very well could be a hardware error, though to my knowledge my design matches reference designs. Any ideas? I'm going crazy over here. I'm probably missing something simple :pinch: