Find and Replace is not working in header files

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Find and Replace is not working in header files

      The project compiles fine, and the directory where the user header files are is included in Preprocessor->User Include Directories.

      Finding on C files work fine and I already tried the different combinations for "Look in Files matching" (*.*, .h, .h and .c etc) as well as look in all solution, etc.

      Please advise.

    • Hello,

      Thank you for your inquiry.
      Such an issue is not known to us.
      We tried to reproduce the issue but find and replace was working in header files as well as expected.
      Which Embedded Studio version are you currently using? Does it appear with the latest version as well?

      Could you provide an example file and reproduction steps?

      Best regards,
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system:

      Or you can contact us via e-mail.
    • Is it the find that's not working, or the replace?

      I think that "look in all solution" just searches the folder containing the Project file, and any folders below that?

      So, if your headers are not there, you have to tell it the "top" folder to start searching from ...