[SOLVED] Problem with flasher portable in standalone MK20DX128

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Problem with flasher portable in standalone MK20DX128

    Hi all,

    I'm having trouble with the flasher portable (not the NEW), when I use it together with JFlash 6.50, it works just fine.
    If I save the config and data file, copy them to the flasher and configure the FLASHER.ini, then try to flash in standalone, it doesn't work and I get the Timeout while checking target RAM in the log file.
    I've been using this flasher both in standalone or with a PC for a few years, with MK20DX256 (kinetis) and STM32 chips without problems so far.

    We have 3 flasher portable devices here. With one of them, I managed to flash the MK20DX128 in stand alone, but can't do it with the other two.
    Is there a way to upgrade its firmware maybe?

    Here's the project file in attachment in case it could help.

    Kind regards,
  • Hi Yves,

    the Flasher Portable was replaced, as you know, by the Flasher Portable PLUS more than 2 years ago. There are some improvements made with the latest JFlash version which were not back ported to the Flasher Portable. The latest version for the Flasher Portable is from 23th Sep 2015.

    We would recommend to upgrade the Flashers to Flasher Portable PLUS. You may check our trade-in program for that. see: segger.com/purchase/trade-in-program/.

    Best regards,

    Michael Fuhs