[SOLVED] Keil uVision μVision - No Algorithm found for: 20000000H - 200000C7H

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Keil uVision μVision - No Algorithm found for: 20000000H - 200000C7H


    I am working on some programming for an STM32F072RB and I am a bit new to ST chips and uVision so please bare with me. :) When I download the program via a JLink Plus to the STM32 the build output shows the following error:

    Source Code

    1. Target info:
    2. ------------
    3. Device: STM32F072RB
    4. VTarget = 3.330V
    5. State of Pins:
    6. TCK: 0, TDI: 0, TDO: 0, TMS: 1, TRES: 1, TRST: 0
    7. Hardware-Breakpoints: 4
    8. Software-Breakpoints: 8192
    9. Watchpoints: 2
    10. JTAG speed: 4000 kHz
    11. No Algorithm found for: 20000000H - 200000C7H
    12. Partial Erase Done (areas with no algorithms skipped!)
    13. No Algorithm found for: 20000000H - 200000C7H
    14. Partial Programming Done (areas with no algorithms skipped!)
    15. Partial Verify OK (areas with no algorithms skipped!)
    16. Application running ...
    17. Flash Load finished at 10:40:40
    Display All

    I am using the default parameters associated with the STM32F0xx 128kB Flash (see image Target Driver Setup.PNG). Additionally I have tried changing the settings around quite a bit as described in this thread but have not had any luck.

    Why would it have an error for the 199 (0xC7H) Byte range of 20000000H - 200000C7H ? Could the 'RAM for Algorithm' (see image Target Driver Setup.PNG) portion be incorrect? The datasheet for the STM32F072RB shows the address range of the SRAM starting at 0x2000 0000 (see STM32F072RB Memory Map.PNG) and the datasheet also describes the SRAM as being 16KBytes (16,384 Bytes or 0x4000 bytes). I tried setting the RAM for Algorithm to 0x20000000 with size 0x4000. Still no luck. Any help would be appreciated.


    Additional Details: I am Running Micro μVision V5.20.0.0

    µVision V5.20.0.0
    Copyright (C) 2016 ARM Ltd and ARM Germany GmbH. All rights reserved.

    Tool Version Numbers:
    Toolchain: MDK-ARM Standard Cortex-M only: 3 user(s) Version: 5.20
    Toolchain Path: C:\Keil_v5\ARM\ARMCC\Bin
    C Compiler: Armcc.exe V5.06 update 2 (build 183)
    Assembler: Armasm.exe V5.06 update 2 (build 183)
    Linker/Locator: ArmLink.exe V5.06 update 2 (build 183)
    Library Manager: ArmAr.exe V5.06 update 2 (build 183)
    Hex Converter: FromElf.exe V5.06 update 2 (build 183)
    Dialog DLL: DARMCM1.DLL V1.14.0.0
    Target DLL: Segger\JL2CM3.dll V2.99.20.0
    Dialog DLL: TARMCM1.DLL V1.10.0.0
    • Target Driver Setup.PNG

      18.84 kB, 623×510, viewed 119 times
    • STM32F072RB​ Memory Map.PNG

      81.26 kB, 687×819, viewed 84 times
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us. But it appears that you are using the Keil Flash loader and it is possible that it has errors.
    Could you give the J-Link Flash loader a try instead?
    How to enable it is explained here:

    Should that still not work could you give J-Link Commander a try and try to Flash the application with the loadfile command?
    More information about J-Link Commander can be found in the J-Link user manual UM08001.
    Could you also provide a J-Link log file of that session?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.