[SOLVED] Segger Free Running Zero Initial Timestamps

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Segger Free Running Zero Initial Timestamps


    When I run Segger SystemView in free running mode with an STM32F446RE NUCLEO board, I get zero timestamps until the RTT buffer overflows, and then I look to be getting meaningful timestamps (see attached screenshots). What could be the issue?
    • Segger_overflow_timestamps.PNG

      74.22 kB, 1,366×731, viewed 300 times
    • Segger_Zero_Timestamps.PNG

      52.22 kB, 1,103×673, viewed 256 times
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us.
    Did you follow the integration guide in the SystemView Manual?
    Additional information can be found here:

    That is all that should be needed to enable SystemView in your application.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.