[SOLVED] Solution build not triggering project build

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Solution build not triggering project build

    When building from the solution level, per-project pre-build steps are not triggered. Attached is a sample project file. Not that the linker is unhappy but that should not matter (and is a completely different SES bug)

    What should happen on solution build:
    • Library_1 builds and calls the test script with "Library_1" as the parameter
    • Executable_1 builds and calls the test script with "Executable_1" as the parmater
    What actually happens:
    • Test script is not called at all
    For solutions there is no option for pre-build. Pre-compile is applied to every single compile file, not what we want. I would expect that a project's build steps would trigger from a solution build but this is not happening.

    This is similar to an abandoned question here
  • Hello,

    Thank you for your inquiry.
    With the latest Embedded Studio V4.18 you should now have the pre build option as a solution option as well.
    Could you give it a try? Is that what you were looking for?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/