[SOLVED] JLink RTT logger for Raspberry Pi - no capture

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JLink RTT logger for Raspberry Pi - no capture

    I'm trying to run RTT viewer and RTT logger on a Raspberry Pi 3 (Raspbian). The target is a nRF52832, using J-Link Ultra. I'm able to run RTTViewer on a Windows 10 system with the same hardware. But when I use the ARM host version of JLink tools, I'm unable to get RTT logger working. There also doesn't seem to be a plain RTT Viewer CLI tool, just the logger, which I haven't been able to get working. Note that I'm able to use the Raspberry Pi to erase and flash .hex files onto the nRF52, so the JLink and Nordic microcontroller works and is connected fine. But RTTlogger tool does not function correctly. See the attached screen shots and annotation.

    On my windows 10 machine, I have to use V6.32i of RTT Viewer, the latest versions don't work for my Windows 10 setup. So I tried several older versions of the ARM host JLink CLI tools on the Raspberry Pi. But all of them failed to capture RTT output. I've tried V6.46 (screen shot below), V6.46i, and V6.32i of the ARM Host JLink tools.

    Link to tool:

    EDIT: Just closing in the loop for future readers. I was able to figure out my issue. The RTT tool for ARM linux isn't smart enough to figure out which channel/terminal to use for the target. The Windows version of RTTViewer figures that out automatically so I never had to pay attention to which channel I was using. The tip is to run your target on a Windows (or maybe x86-hosted Linux machine), using the much better RTTViewer there. Watch the log for which terminal you're using. Then use the screen shot below to explicitly input the terminal. Specifically, I entered "0" when prompted for terminal, and "SWD" when prompted for interface. If the tool doesn't know what target to use, you can go back to the Windows version of J-Flash's UI, and enter the same text shown in the target dropdown selection corresponding to your micro.

    • Rpi-RTT-windows.png

      35.64 kB, 826×298, viewed 51 times
    • Rpi-RTT-Pi.png

      60.96 kB, 826×658, viewed 57 times

    The post was edited 1 time, last by nRF52 ().

  • Hello,

    Thank you for your inquiry.
    The J-Link software package for ARM hosts comes without support so please understand that we can't put time into this issue.

    Alternatively we recommend using an external PC that is connected to the Raspberry via Network and use a Telnet Client on the external PC to access the RTT data via port 19021.
    To enable this RTTTelnetAllowNonLocalClient must be set in the Raspberry instance. More information can be found in the J-Link user guide UM08001.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.