J-Trace M3 not enumerating

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • J-Trace M3 not enumerating

    Hi

    I used my J-Trace about a week ago and all was fine. Today, I re-connected my J-Trace and now it does not even try to enumerate. Only the Power led is on. I tried different USB cables, other PC's - nothing! My J-Link is still working fine.

    Could it be something to do with v4.20g that I installed? This was the first time that I connected my J-Trace to my PC after I installed v4.20g of the J-Link driver. But now it do not even want to try to enumerate on any PC, regardless of the J-Link driver.

    Is this the end of my J-Trace? ;(

    Any help would be highly appreciated.

    Regards,
    Gawie
  • Hi Alex

    No, there was no firmware upgrade after I installed V4.20g. There was a fw upgarde early Sept (last month), but it worked fine afterwards.

    I suspect that something went bad on the USB side as it does not even try to enumerate once connected - maybe some hardware fault ?( . But it is very funny - it was lying on my desk (unconnected) for about a week and when I connect it again, gone is the USB enumeration.

    Any other suggestions or should I send it back for a replacement?

    Regards,
    Gawie