configuring fsmc 8080 interface with SSD 1963 driver

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • configuring fsmc 8080 interface with SSD 1963 driver

      Hi I'm configuring FSMC 8080 interface with SSD 1963 driver to interact with my LCD. The MCU is stm32F469VETx. The program runs but doesn't display anything to the screen when I'm trying to display simplest "hello world" string or anything else.
      Below are some of the configurations I use:
      Images
      • Kometa1.PNG

        65.97 kB, 1,004×935, viewed 65 times
      • Kometa2.PNG

        103.07 kB, 1,001×938, viewed 84 times
      • Kometa3.PNG

        68.73 kB, 997×936, viewed 62 times
    • Have you verified that your underlying hardware is working first? ie board <-> LCD?

      (I'm working on a project now using an STM32H7 CPU, and before even thinking about integrating ewWin, I first worked through some of ST Micro's LCD examples in the FW pkg to get basic LCD display working)

      ie this looks like the FW package you probably have for CubeMX for that processor?

      STM32Cube_FW_F4_V1.24.0\Projects\STM32469I_EVAL\Examples\LCD_DSI....

      Now the 'msp' config, ie GPIO pin assignments in their examples may not line up exactly with your board?
      (if you are using a custom board or an eval board?)

      So if that's the case, you would use CubeMx to generate the code as you are doing in your example above, and copy and paste the appropriate 'Init' functions from the generated code into their examples... replacing functions that assign GPIO pins,etc with your specific ones..

      This is how I did it, and worked out setup things, etc, so I could get LCD functionality going, etc... then after ALL of that was working right, I brought in emWin...

      but you need to verify the hardware itself is working right before jumping into emWin stuff...