[SOLVED] problem with background memory access error(cortex R4 devices)

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] problem with background memory access error(cortex R4 devices)

    I am using Segger Jlink Ultra+. The IDE that we are using is Code Composer Studio v.8.3. I also use TMS570LS which is Cortex R4 device. The problem is I get an error when I want to use RTT in J-scope. If I choose a variable in RTT, I get an error which can be seen in the picture as "Initialising Jlink connection failed." Is there any solution for this? I also get error for HSS option but as far as I understand, there is no support for cortex R targets

    As far as I understand, the problem is about background memory access and we need to write a code(script file) which includes something like "CORESIGHT_IndexAHBAPToUse = x". If there is a solution like that, can you send me the required script file? Where should we put this script file in our Code composer studio project?

    I also have J-trace pro for all arm cortexes.When I use Ozone debugger, I cannot see real time data change if I use it with TMS570. I get some error about background memory access.

    If I use it with a cortex M4 microcontroller, everything works fine.

    The post was edited 3 times, last by cmldmr ().

  • Hello,

    Thank you for your inquiry.
    We received you inquiry via our support system as well.
    To make sure no information gets lost between different channels this thread will be closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.