[Linux] JLinkExe RTT is slow again in latest release

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [Linux] JLinkExe RTT is slow again in latest release

      Hi Segger,

      I am using RTTClient to do firmware upgrades, and I noticed there is a big delay again on transmitting TCP packet on port 19021.
      This has been discussed before:
      [SOLVED] RTT slow not usable anymore


      I can confirm that:
      * JLinkExe V6.32a was FAST (~10ms delay on TCP transmit from port 19021)

      * JLinkExe V6.46c is SLOW (~300ms delay on TCP transmit from port 19021)
      * JLinkExe V6.44c fixed the issue again, and is FAST again (also documented in the thread mentioned above)

      * JLinkExe V6.46e: REGRESSION! This version is SLOW again, with the ~300ms delay back in!

      What exactly is happening? Is there a way we can control the TCP buffering behavior manually?
      This makes upgrading JLink version difficult and requiring close monitoring and testing.
    • Hello maximevince,

      Sorry to hear that you are facing issues with our software.

      Could you please tell me which application exactly you are referring to?
      You are mentioning JLinkExe (J-Link commander) as well as RTTClient.
      The thread you linked to refers to the RTTViewer.

      Additionally, could you please tell me what you are doing with that application (e.g. what do you do to see the "slow" behavior?).


      Thank you very much in advance and sorry for any inconveniences caused by this.
      Best regards,
      Leon.