MSP432 cannot be flashed

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • MSP432 cannot be flashed

      I have a J-Link for Arm 8.0 and I'm trying to flash an MSP432 with 1MB internal flash (MSP432P411Y).
      The J-Link drivers are v6.44h.
      If I try to program the chip with UniFlash from TI or with IAR Embedded Workbench (meaning, only image download without debugging), the tools report a programming failure. It seems that only the first 512KB can be programmed. Addresses above this limit cannot be programmed.

      If instead of using the J-Link I use a TI MSP-FET debugger, everything works fine with the same image.
      I guess there is a problem in the J-Link drivers that prevents the image to be flashed.

      Any help would be very appreciated.
    • Hello,

      Thank you for your inquiry.
      Such an issue is not known to us.
      The UniFlash is not our software so we can't comment on it working or not.
      But you should be able to Flash the MSP432P4 with Segger software like J-Link Commander or J-Flash.
      They are available in your J-Link software install folder.
      Could you try Flashing with J-Link Commander for example?…ty_using_J-Link_Commander
      After successful connect use command loadfile and specify the binary/hex that should be programmed.

      Does that work?
      If not could you provide a J-Link log file of the failing session?

      Best regards,
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support contact us per e-mail.
      Alternatively our support system can be used as well:
    • Thank you for the reply
      I think one of the problems is the erase algorithm.
      I've tried the following:
      IAR Embedded Workbench 8.32.1
      Just create a dummy main.c project for the MSP432P411Y
      Download the dummy project in the target
      Now in the memory window, select Flash as memory
      Now try to fill the flash with 0x0 from address 0x0 length 0x100000 (1MB)
      Then go at address 0x80000 (upper 512KB start): the memory has NOT been filled!
      If you try to fill from address 0x80000 for length 0x80000 (upper 512KB), it doesn't work either.
      Also with the JLink commander, if I issue an Erase command, the upper 512KB are not ereased.

      Edit: I've also tried with a J-Trace for Cortex-M V3.2, same result. I've downloaded the latest J-Link drivers (6.46f), same result.

      The post was edited 2 times, last by D.F. ().