[SOLVED] Debug mode license error

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Debug mode license error

    Hi All,

    I'm using floating license for my KEIL IDE and NRF controller.

    I'm able to compile and run the code from KEIL but I'm not able to work in debug mode. I'm getting "Error: *** License Mapping Failed! *** Debugger aborted !" this error.

    My Jlink version version is 6.46d and windows 10 OS

    Here is the build output:

    Target info:
    Device: nRF52840_xxAA
    VTarget = 3.300V
    State of Pins:
    TCK: 0, TDI: 1, TDO: 1, TMS: 1, TRES: 1, TRST: 1
    Hardware-Breakpoints: 6
    Software-Breakpoints: 8192
    Watchpoints: 4
    JTAG speed: 1000 kHz
    Full Chip Erase Done.
    Programming Done.
    Verify OK.
    * JLink Info: Reset: Halt core after reset via DEMCR.VC_CORERESET.
    * JLink Info: Reset: Reset device via AIRCR.SYSRESETREQ.
    Application running ...
    Flash Load finished at 17:43:28
    Error: *** License Mapping Failed! *** Debugger aborted !

    Can anyone help me to fix this issue.

    Thanks in advance,

  • Hello,

    Thank you for your inquiry.
    Such an error is not known in our sourcebase so it is most likely coming out of Keil.
    You can verify this by enabling the J-Link log:

    There all error messages from J-Link software are logged.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.