[SOLVED] RTT viewer command line --autoconnect error 9009

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] RTT viewer command line --autoconnect error 9009


    I am trying to get the --autoconnect feature of JLinkRTTViewer.exe to launch the viewer and start a new connection over usb like so:


    1. "C:\Program Files (x86)\SEGGER\JLink\JLinkRTTViewer.exe" --autoconnect --serialnumber 123456789 --device STM32F427II --interface swd --connection usb

    When I launch the above command, the window briefly appears then the application exits with error code 9009 (echo %ERRORLEVEL%). Without --autoconnect works but with the dialog for setting up the device.

    Serial number is the right one (tested with JLink.exe).

    Version is V6.46.d.

    How can I get RTT Viewer to launch from command line without the dialog?

  • Hello Joe,

    Thank you for your inquiry and for reporting this issue to us.
    Your command line is correct.
    A bug was introduced with the most recent version (V6.46d) that causes --autoconnect to crash the RTTViewer.
    This bug has already been fixed internally. The fix will be part of the next release of the J-Link software package, which is planned for Friday this week (14th June 2019).
    We are sorry for any inconveniences caused by this.

    If you are interested in a preliminary version of the J-Link RTT Viewer containing this fix, please do not hesitate to send me a private message.
    Best regards,