[SOLVED] Nordic License on MacOS Not Working

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Nordic License on MacOS Not Working

    Hi, I just downloaded Segger Embedded Studio 4.16 and received a free Nordic License. I can install the license and everything looks fine but it still says Non-Commerical License at the top of the window and every time I build I get the "No commerical-use license detected" window. I'm running macOS Mojave.

    Thanks.
  • Hello,

    Thank you for your inquiry.
    Did you make sure that the project your are building debugging is using a Nordic device? The license is only valid for project where Nordic devices are selected.
    Further troubleshooting steps can be found here:
    wiki.segger.com/Get_a_License_…dic_Semiconductor_Devices

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.
  • If you haven't already solved this, be sure you open SES, hit "Continue" on the license notice, then open a Nordic SDK solution from the file menu. The default "Hello" project is what's tripping up the license detection. Once you have a Nordic project open, then you can add your key and have it stick.