[SOLVED] Flasher portable Plus with STM32F469 including external QSPI flash

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Flasher portable Plus with STM32F469 including external QSPI flash


    we are using a Flasher Portable for standalone flashing of several ECUs and we encountered problems in flashing a PCB with an STM32F469 with an attached external QSPI flash.

    The setup is using the recommended procedure to patch the JLinkDevices.xml and provide a custom loader for flashing attached QSPI flash. This setup works properly with J-Flash and Flasher Portable, i.e. PC connected to flasher and flashing is done by J-Flash.
    When we create a .cfg and .dat file to use it in Flasher Portable standalone mode, the flash process starts and sometimes seems to succeed, but the display shows 0x000000000 as address during verify, the progress bar increases to 200% and sometimes errors after verification are reported.
    Therefore this approach is to risky to use with service personnel. We observed this with the current J-Flash software 6.44g, however there have been reports that everything functions well with an older firmware.
    Is there something we could do on our side to get rid of this issue? What can we do to figure out if the job itself or the firmware causes this?