[SOLVED] RTT Control Block not Found (only on auto detect) on STM32H7 Nucleo

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] RTT Control Block not Found (only on auto detect) on STM32H7 Nucleo


    After digging around a bit in SystemView i want to ask the question wether it is possible to get it to work that the auto detection of my RTT block is working on my stm32h7 working on a Nucleo board.

    As debugger i'm using the installed debugger on this board flashed with j-link.

    My RTT block is placed in Ram at address 0x2000xxxx depending on the code and if i place the rtt block detection to this address systemview works very well. But every time i change my code (create new tasks, delete tasks, trying around) i have to find out the new address of the RTT block.

    Why SystemView is not able to auto detect the RTT block address? Is there something i can do that autodetection works?

    technical data:

    SystemView embedded source V2.52h
    SystemView SW: V2.52d
    SoC: STM32H743 on Nucleo Board
    Attollic TrueStudio v9.1.0

    If you need any further information about my system please ask.

    Thanks in advance

  • Hello Daimonion,

    Thank you for your inquiry.
    RTT control block autodetection for the STM32H7 series will only work for RAM area 0x20040000 and up due to some device specific defaults.
    So you need to add other RAM areas manually. This can be done in multiple ways. They are all described in the J-Link user manual UM08001 in chapter RTT.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.