[SOLVED] Can't program RZA1H custom board

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Can't program RZA1H custom board


    The J-Link Lite included with Renesas RSK board works fine to program the on-board QSPI flash devices. I used the JLink commander version V634h.

    It doesn't seem to work when tried to program a custom board that was designed with the same controller device RZA1H as in RSK board.
    The custom board differ in the following:
    (1) It uses a different QSPI flash (S25FL512S) but supported by JLink program.
    (2) It configures SPBIO port 1 as follows (SPBIO port 0 is the same)
    SPBIO01 P8_14
    SPBIO11 P8_16
    SPBIO21 P9_0
    SPBIO31 P9_1

    Do I need notify the JLink commander (say by command line option) the custom change in the configuration.

    Can Jlink identify the ports to which the QSPI devices connected to for automatic programming, as there are only couple combinations available in the device?

    Thanks in advance

  • Hello EsKay,

    Thank you for your inquiry.
    The Flashloader that comes with J-Link software for the QSPI for that Chip works only with exactly the pins that are used on the eval board.
    If you are using other pins it will not work.
    So you would need to adjust the Flash loader to fit your used pins. The Flash loader can be requested using our official support channel.
    For more information see my signature.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.