[SOLVED] J-Scope fails silently on configuration

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Scope fails silently on configuration


    I've been trying to use Segger J-Scope with our IMXRT1052 PCB (developed internally) over SWD (using a J-Link Pro, running firmware 6.42f). The program shuts down silently (with no message) upon clicking "OK" in the J-Scope Configuration dialog; this occurs both with version 5.10d and the beta version 6.11m. I'm running under Windows 10 Pro, version 1803.

    I follow the following process:

    1. Start J-Scope and select to create a new project.
    2. I select a USB connection, checking the Serial No box and entered my probes s/n.
    3. I select my target device, by checking the box, clicking the elipsis icon, and select the NXP MIMXRT1052DVL6B device in the dialog (clicking OK).
    4. I leave the target interface and speed at default values (SWD and 4000kHz).
    5. I leave the Sampling Source at the default value ("HSS (asynchron)").
    6. I leave the sampling period at its default value (100µs).
    7. I select the Elf file (.axf) generated by my IDE (MCUXpresso 10.2.1 Build 795).
    8. I select our jlink script file in J-scope v6.11m (which allows it to be selected, but not 5.10d)
    9. I click OK; the configuration dialog disappears, and then, after one or two seconds, the entire J-Scope application closes.

    I had already loaded my application onto the processor, using MXUXpresso, and disconnected, leaving it running in external SDRAM.

    What could I be doing wrong here? I was hoping this would be a fast way to check some functionality without instrumenting certain aspects of my code!

    Many thanks,

    Andrew Walsh.

    The post was edited 1 time, last by AndrewWalsh ().