[ABANDONED] Ozone : trace point start and stop has no effect

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] Ozone : trace point start and stop has no effect


    With a J-Trace cortex M and stm32F429ZET6 :

    When I run the soft with ozone, I have the full trace.
    Now, I want to trace only some portions of the code. I added a start tracepoint and a stop tracepoint.
    I'm sure that the execution goes through this code. I run the soft, pause it after some iteration and I there's
    nothing in the trace window.

    Is there some thing I've forgotten to do?

    • trace2.jpg

      129.01 kB, 738×514, viewed 104 times
  • Hello Julien,

    Thank you for your inquiry.
    Which trace window are you referring to exactly?
    For reference I used the J-Trace PRO Cortex-M tutorial project for the eval board that is shipped with the J-Trace PRO.
    Attached you can see a screenshot of me using trace start and stop points. As you can see only that part will be traced and the instruction trace window will show trace data only from that area.
    Can you verify this working with your Cortex-M Trace Reference Board and the tutorial project as well?

    Best regards,
    • Capture.PNG

      6.7 kB, 312×146, viewed 65 times
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.