[SOLVED] SES 4.16 not showing RTT output

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SES 4.16 not showing RTT output

    After upgrading to 4.16, none of my projects output RTT text, except for a line feed. 4.12 works just fine if I reinstall it. I can also disable RTT output in the project options, run the command line JLinkRTTClient and that works.

    I've also made sure to update the SEGGER_RTT_*.c source files in the project to the latest from JLink 6.44d, which didn't make any difference.

    I'm running macOS 10.14.4 and using a Nordic nRF52840-DK. Any of the example projects in Nordic SDK 15.3.0 show the same behavior after modifying sdk_config.h to enable the NRF_LOG RTT backend.

    Any suggestions are appreciated, thank you!
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us.
    We tried to reproduce the issue but RTT data was showing up just fine in Embedded Studio 4.16.
    Attached you can find the example project used.
    Could you test your setup with that project. Is RTT output working as expected?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.