Hidden warnings, modifying the include path, path prefix

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hidden warnings, modifying the include path, path prefix

      Hello,

      I am using (SEGGER Embedded Studio for ARM, Release 4.12 Build 2018112601.37855, Windows x64) and there are 3 things that I noticed that I would would like some help with/suggestions. The first 1 item is obviously significantly more important.

      1) When I compile and there are warnings it requires 2 or 3 mouse clicks to actually view the warnings. You can see what I get in the first attachment. I have looked, and I can not find a setting to automatically expand warnings as well as errors. Nor can I find a key that would take me to the first warning/error.



      2) I've looked everywhere in the project settings, and I can't find the place in the IDE to modify the include path. And so far I've had to go into the emProject file.

      3) With #2, going into the emProject file, instead of ../../../../../../ it would be great if your examples and the IDE would use a SDK environment variable. And then create relative paths using that. For example, I've added to my .emProject files

      SDK="../../../../../"

      and thus my includes looks like

      c_user_include_directories="../../..;../../../config;$(SDK)/projects/CommonBtComm/include;$(SDK)/projects/PolaraLibrary/Buffer;$(SDK)/components;$(SDK)/components/ble/ble_advertising;

      and then the source files look like

      <folder Name="Board Definition">
      <file file_name="$(SDK)/components/boards/boards.c" />
      </folder>


      and

      <folder Name="Application">
      <file file_name="../../../main.c" />
      <file file_name="../config/sdk_config.h" />
      <file file_name="../../../serial_comm.c" />
      </folder>


      Now to fully geek out, you could add PRJ="../../.."

      <folder Name="Application">
      <file file_name="$(PRJ)/main.c" />
      <file file_name="../config/sdk_config.h" />
      <file file_name="$(PRJ)/serial_comm.c" />
      </folder>


      thanks in advance.
    • Hello,

      Thank you for your feedback.
      1: Simply press F4. This should take you to the first warning.

      2: Try project options->Preprocessor->User include directories

      3: You can set as many macros as you want under Tools->Options->Building->Build->Global Macros

      Best regards,
      Nino
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support contact us per e-mail.
      Alternatively our support system can be used as well: segger.com/ticket/