[SOLVED] Nordic SES and mbedTLS with Zephyr

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Nordic SES and mbedTLS with Zephyr

    HI,
    I am developing software in SES V4.14 Nordic version (downloaded using NRF connect) for Nordic NRF9160 DK and everything works great until I tried to add mbedTLS.
    Nordic sample uses Zephyr framework and works great , I tried to add mbedTLS by adding configuration to the .conf file and it give me error : error: #include expects "FILENAME" or <FILENAME>.
    It seems that SES don't find the correct file of config.h while there is config.h file...

    I asked in Zephyr slack and they said its an integration issue with CFG_FILE and SES , do you aware of it ? do you know when the fix will release ?


    Thanks,
    David
    Images
    • image (1).png

      18.33 kB, 520×243, viewed 15 times
    • image.png

      34.22 kB, 950×268, viewed 10 times
  • Hello David,

    Thank you for your inquiry.
    Zephyr and mbedTLS support is not provided by Segger. We recommend contacting Nordic in this regard.
    From the error message it seems that the macro MBEDTLS_CONFIG_FILE is not defined.
    You could try defining this manually or replace it with the actual file path.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/