[SOLVED] JFlash resets QSPI bit in IS25LP128 flash chip

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JFlash resets QSPI bit in IS25LP128 flash chip


    we use an IS25LP128 QSPI flash chip together with an LPC43xx uC. The IS25LP128 can be ordered in different versions.

    1. A version which has a fixed byte on a specific memory location which indicates QSPI functionality.
    2. A version where this byte is programmable by software.

    We use the second version at the moment and JFlash clears that every time we reprogram the flash chip. This is a little annoying since the boot after the flashing is very slow since the QSPI byte is erased and signals to our software that the flash chip does not support QSPI mode. We always have to reprogram the QSPI byte flag. For the IS25LP128 it is bit 6 in the status register.

    Would it be possible to exclude the status register from being reprogrammed by JFlash every time ?

  • Hello Hans,

    We received your inquiry via Supportsystem as well where the topic has been solved.
    A fixed version will be available with our next J-Link software beta.

    This thread will be closed now to avoid double information.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.