[SOLVED] Not able to connect JLINK with target hardware nRF52480 chipset

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Not able to connect JLINK with target hardware nRF52480 chipset

    Hi All, I am using JLINK BASE and trying to connect the same using 10 Pin connector on the target hardware.
    This connector is basically contains the 4 pins major - SWDIO , SWDCLK,SWO,RESET.
    But after connection I am trying to flash BLE application from SEgger Embedded Studio and I am seeing error as attached screenshot.

    Failed to connect to target.
    No idcode detected.
    Please check connection and target interface type.

    So please suggest me is any interface need to configure.

    Also I tried to execute the commands from "nrfjprog" tool and I am observing that error as below :

    ERROR: Low voltage detected at the target. Please make sure the device is
    ERROR: properly supplied.

    Can you please share me how can I detect the BLE chipset with JLINK.


      359.16 kB, 1,920×1,080, viewed 291 times
  • Try to set connection speed 0 (i.e. autodetect possible speed). You may first try with JLink utility itself, just to check if it helps.

    Also, while SWD indeed uses 4 pins for various control lines, you should also connect GND and maybe Power+ (if you target is not powered via another source).

    The post was edited 3 times, last by ArtemS ().