[SOLVED] Segger JLINK is throwing Bad JTAG communication Error

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Segger JLINK is throwing Bad JTAG communication Error

    I am debugging the Cypress's FX3 USB Superspeed Controller (CYUSB3014) device using the Segger JLink debugger.

    J-Link Serial Number is 58001068.

    I have seen the following error:
    Bad JTAG communication: Write to IR: Expected 0x1, got 0x0 (TAP Command : 2) @ Off 0x5.
    When I probe the JTAG lines using Logical Analyzer. I have seen the following.

    Shift-IR has sent along with TDI data as F and TDO as 1; Shift-IR TDI F, TDO 0; Shift-IR TDI 3, TDO 1; Shift-IR TDI 1, TDO 1;

    In the above four cases, JTAG Communication was fine.
    But when Shift-IR TDI 3, TDO is 0; Shift-IR TDI 1, TDO is 0; I have seen the above error (Bad Communication). This can be seen in the trace as well (at the last part of the trace).

    Can you please comment on this possible case for JTAG Bad Communication?

    I have attached a log file. This has captured while the firmware was downloaded to RAM and JTAG debugging has started from the MAIN function.

    Application Software to open the Log is Saleae Logic 1.2.18.
  • Hello,

    Thank you for your inquiry.
    The CYUSB3014 is currently not officially supported:

    If you are entitled for support in this case you can contact us via our official support channels.
    You can find more information about this in my signature.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/