[SOLVED] debugging without download or reset - possible ? how ?

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] debugging without download or reset - possible ? how ?

    Please could anyone tell me:
    o Is it possible with SEGGER emStudio or JLINK Ozone (I have both installed under MacOSX) to
    debug a USB + JLINK attached NRF52 target without resetting it or installing a new image?
    It does not seem to be (I cannot see how, anyway) , but perhaps there is a way?
    ie. what I'd like the debugger to do:
    o attach to my NRF52 (cortex-m4) target with JLINK over USB
    o verify that the loaded image on the device is the same as the latest built image,
    if so, do NOT download a new image;
    o Put the CPU into pause / halt state - DO NOT RESET THE CPU
    o allow me to inspect memory / set breakpoints in the running image, which
    has not been reset.
    Is this possible?
    With all methods I have tried, emStudio / Ozone always downloads the
    new image & resets the CPU.
    Any suggestions much appreciated!
    Thanks & Best Regards,

    To be clear :

    1. There appears to be no way to do this in emStudio's debugger -
    it always builds & downloads an image and resets the CPU.

    2. Having installed Ozone for MacOSX, any attempt to invoke
    the down-arrow menu items 'Attach to Running Program' or
    'Attach & Halt Running Program' results in an error:
    Debug.SetConnectMode (CM_ATTACH);
    Connection failed

    This is despite being able to connect to the JLINK over USB with
    emStudio with no problems.

    Is this because it is a free non-commercial edition of Ozone I have ?
    Would connection attempts succeed if I purchased a license ?
    Or is halting the running program not supported for the NRF52 ?
    If so, Ozone should tell me so rather than just the 'Connection failed'

    3. Having set the emStudio option:
    Tools->Options->Debug->Ozone Executable to the correct '/Applications/SEGGER/Ozone.app'
    application directory, I 'Connect JLINK' successfully, but when I click on 'Debug with Ozone',
    nothing happens. Is this because I am using an unlicensed version of both emStudio and Ozone ?

    Does anyone know of any third-party tool that can do the job
    (debug a running program on a USB connected JTAG target without
    downloading a new image or resetting the CPU )?
    If so, please let me know.

    The post was edited 1 time, last by jvd66 ().

  • With Ozone it should be possible.
    I use windows ozone version V2.60o and
    "Attach & Halt" is working for all my devices STM32H7xx, STM32F4xx, STM32F1xx

    EmStudio option "Debug with Ozone" is also not working, but this is no problem for me.
  • Hello jvd,

    Thank you for your inquiry.
    We received your inquiry via e-mail as well.
    To make sure no information is lost between different communication channels this thread will be closed now.
    Generally attaching with ES and Ozone should always work, not matter your leicense or OS you install with Embedded Studio.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.