[SOLVED] SAM ICE failed to connect to SAML11E16A

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SAM ICE failed to connect to SAML11E16A

    Hello
    I try to connect SAM ICE to SMAL11E16A via SWD (pin31, 32, reset, GND, VCC), but it reports "Failed to launch program, Error: numeric error 1" when I tried to debug the code in Atmel studio 7. Also, in Atmel Studio 7, Tools>> Device Programming , I set SWD clock to 2MHz, and click"Read", I got message " Error connection to device over SWD, Unable to enter programming mode. Verify device selection, interface settings, target power, security bit, and connections to the target device." I checked all above items, all look ok. I tried ATMEL ICE on my SAML11 PCB, it works with ATMEL ICE very well.
    With a J-link commander V6.40, I got some message below. From the message, looks like SAM ICE does not support cortex-M23 (used by SAML11), however, according to SAM L11 datasheet, the SAM ICE is supposed to work with SAML11. Does anyone have similar problem, any idea how to solve this problem? Thanks

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    TIF>s
    Specify target interface speed [kHz]. <Default>: 4000 kHz
    Speed>2000
    Device "ATSAML11E16A" selected.
    Connecting to target via SWD
    InitTarget()
    Device will be unsecured now.
    RAM execution enabled.
    Found SW-DP with ID 0x0BF11477
    Scanning AP map to find all available APs
    AP[1]: Stopped AP scan as end of AP map has been reached
    AP[0]: AHB-AP (IDR: 0x04770025)
    Iterating through AP map to find AHB-AP to use
    AP[0]: Core found
    AP[0]: AHB-AP ROM base: 0x41003000
    CPUID register: 0x411CD200. Implementer code: 0x41 (ARM)
    Found Cortex-M23 r1p0, Little endian.
    ****** Error: Specific core setup failed.
    Cannot connect to target.
    J-Link>
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    SEGGER J-Link Commander V6.40 (Compiled Oct 26 2018 15:06:29)
    DLL version V6.40, compiled Oct 26 2018 15:06:02
    Connecting to J-Link via USB...O.K.
    Firmware: J-Link ARM V8 compiled Aug 26 2015 15:08:21
    Hardware version: V8.00
    S/N: 28013032
    License(s): RDI, GDB
    OEM: SAM-ICE
    VTref=3.320V
    Type "connect" to establish a target connection, '?' for help
    J-Link>
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
  • Hello,

    Thank you for your inquiry.
    The SAM ICE you are using is based on a J-Link Base V8.
    Cortex-M23 are only supported on V9 or later:
    wiki.segger.com/Software_and_H…ures_Overview#J-Link_BASE

    So to properly work with the L11 you would need to get a newer J-Link Base or SAM ICE.
    At Segger we offer the Trade in program for such cases so you can upgrade to the latest version with a discount:
    segger.com/purchase/trade-in-program/


    Best regards,

    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/