emWin refreshing is slow

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • emWin refreshing is slow

      Hello,

      I am using IMXRT1050-EVKB board. I have interfaced a 2.2 TFT SPI 240X320 display module. The display module uses Il9341 driver. After GUI_Init, when I am calling
      GUI_SetBkColor(GUI_RED);
      GUI_Clear();
      GUI_Delay(10);
      GUI_SetBkColor(GUI_GREEN);
      GUI_Clear();
      GUI_Delay(10);
      GUI_SetBkColor(GUI_BLUE);
      GUI_Clear();
      GUI_Delay(10);

      With the above code, I expect the background colour of TFT Display to change instantly. But I can see the background color, Red/Green/Blue scrolling from top to bottom. It is so slow, that it could be figured out visually. Even my further code displays slowly and i can see each alphabet loaded from left to right line by line. What I've known is that it should display/load any changes in one go rather than filling up character by character from top to bottom. It takes more than a second to execute each set of GUI_SetBkColor and GUI_Clear functions. My SPI bus speed is 16MHz.

      I have also implemented using parallel interface with a 2.4 TFT 240X320 display module having ILI9325 driver on the same board. But still the problem persists. Kindly let me know how can I solve this issue.

      Regards,
      Snehal
    • Hello Sven,

      My board is clocked at 600MHz. I am using IMXRT1050-EVKB development board. I have implemented the code using SPI based ILI9341 driver and parallel interface using ILI9325 driver. The following are the configuration files for both of them.

      Regards,
      Snehal
      Files