[SOLVED] Register definition file causing issues

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Register definition file causing issues

    I am using embedded studio v4.12. After loading the LPC5410x.svd file, debugging slows down by factor of 1000 (maybe more). Each "step over" takes 2-3 minutes instead of 1second. This same file worked fine in version 3.42b, so I wouldnt say its corrupted definition file. I didnt noticed any issues on other mcu's I am using. That doesnt say much as I am only using 4 different mcu's, but still its not affecting performance on the others.

    Removing the "Register definition file" from debugger, returns everything to normal. Debugging is a breeze again without it, just the hot inferno breeze as I dont see any of the registers I change in the code :) :rolleyes:

    Anyone had similar experience ?

    Solution ?
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us.
    Could you provide us with the .svd file for reference?
    Does this issue happen only if certain peripherals are active or with all of them?`

    Bestr regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.
  • Hi,

    Attached is the svd file. Issue happens as soon as I attach the svd file and do the first debugging over SWD. I dont even enable any of the peripherals in the register viewer.
    Didnt try JTAG, as I dont have compatible board. Removing the svd file, everything is back to normal.