[SOLVED] RTT viewer connected but no output with STM32H743

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] RTT viewer connected but no output with STM32H743


    I used RTT files from JLink version 6.42c (working fine on a STM32F407 project)
    now i tried the same files on a STM32H743

    _SEGGER_RTT symbol is placed into RAM section 0x2000.0000

    but no output is visible on RTT viewer

    any ideas?


    just found a "workaround"....
    when i manually set the address during RTT viewer configuration (to 0x2000043c) everything is fine
    (auto detection and search range doesn't work)

    The post was edited 1 time, last by Jordan ().

  • Hello,

    Thank you for your inquiry.
    The automatic search range for RTT control block for STM32H7 starts at 0x24... as this RAM is always available.
    If another memory location is used it has to be set manually by the user.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.