[SOLVED] Recording stops with "Invalid packet received" when using assembly version

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Recording stops with "Invalid packet received" when using assembly version

    Hello again!

    When using the assembly version V2.52f of SEGGER_RTT_WriteSkipNoLock, SystemView V2.52d stops with an "Invalid packet received" error.

    When SystemView recording starts for the first time, I get *some* correct records until the error message.

    Subsequent SystemView recordings throw the error immediately.

    The C version works without any problems.

    (I'm using a Segger J-Trace PRO, FreeRTOS 10.1.0 running on a STM32H743 (without cache at the moment)).
  • Hello,

    Thank you for your inquiry.
    The current SystemViewV2.52f_Src files from our website are faulty in regards to the RTT files.
    For now we recommend using the RTT files shipped with the latest J-Link software version.
    The SystemView shipping files are currently under review and should be updated shorty as well.
    Sorry for any inconvenience caused.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/