[SOLVED] Issue related to debugging GHS compiled elf on S32K

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Issue related to debugging GHS compiled elf on S32K


    Please suggest whether we need to make any compiler optimization changes, for debugging GHS compiler to generate elf to flash on S32K controller.
    Now when I try to flash this elf, the download is successful but I am not able to debug. The running target cannot be halted and breakpoints are not hit.

    Thank you
  • Hello,

    Thank you for your inquiry.
    Native J-Link support in GHS debugger has been removed by Greenhills a while ago. So at this current point in time we can't give any assistance with Greenhills setups as they are no longer supported.
    For any setup related issues we suggest contacting Greenhills support.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.