[SOLVED] STM32 Example Project and Timer Problem

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] STM32 Example Project and Timer Problem

    I am trying to get a simple STM32 timer example project to run under Embedded Studio.
    The example (TIM_TimeBase), builds and runs fine with the Keil toolchain.
    The project also imports, builds and runs within Embedded Studio also but the timer callback is never hit.
    It appears that the timer enable is stuck in HAL_TIM_Base_Start_IT().
    Any ideas as to the cause of this?

    Note: I am using a Nucleo-64 STM32F091 dev board as hardware.


  • Hello Joe,

    Thank you for your inquiry.
    When importing more complex projects from IAR or Keil to Embedded Studio there are certain steps that need to be considered regarding compatibility.
    An example guide for a proper import can be found here:
    The example is for IAR but the same points apply to Keil as well.

    Should the imported project still fail after following the steps we suggest contacting ST support in regards of ST HAL issues as that software package is maintained and supported by ST.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.