[SOLVED] VTarget = 0.0V but JTAG pin 1 = 3.3V

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] VTarget = 0.0V but JTAG pin 1 = 3.3V

    My J-Link EDU is unable to connect with my target processor (an ATSAME54P20). Here's what J-Link Commander reports upon startup:

    Source Code

    1. SEGGER J-Link Commander V6.41a (Compiled Nov 27 2018 14:10:26)
    2. DLL version V6.41a, compiled Nov 27 2018 14:09:51
    3. Connecting to J-Link via USB...O.K.
    4. Firmware: J-Link V9 compiled Oct 25 2018 11:46:07
    5. Hardware version: V9.40
    6. S/N: 269402808
    7. License(s): FlashBP, GDB
    9. VTref=0.000V
    10. Type "connect" to establish a target connection, '?' for help
    11. J-Link>
    Display All

    The suspicious part is "VTref=0.000V". But when I measure the voltage on pin 1 of the 20 pin JTAG connector, I see 3.3V. Does this indicate a faulty J-Link? Or are there other things that could cause this?
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us. If you measure 3.3 V on Pin 1 J-Link should see it too.
    Are you using the original JTAG cable shipped with J-Link? If yes, do you have another cable to test against?
    Just to be sure could you double check for correct cable orientation?

    Should VTref keep showing 0 V no matter what JTAG cable is used it is most likely defective.
    As the references J-Link is out of maintenance for quite a while now we suggest making use of our trade in program:

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.