[ABANDONED] J-Flash will not Program Renesas Synergy S3A3

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] J-Flash will not Program Renesas Synergy S3A3


    I am trying to program a R7FS3A37A device via SWD with J-Flash Lite.

    When I run he program the specific device selected I get an error trying to erase the device. "ERROR: Could not erase chip."

    If I change to a generic CORTEX-M4 device I can erase the chip, but I still get an error when trying to program device "Error: Could not download file."

    I have also noticed that the Flash Size and RAM Size are both wrong when looking at the R7FS3A37A. The Flash Size is listed as 17309740 Bytes, it is actually 512k of user area stating at 0x00 and 8k of data area starting at 0x4010 0000. The ram is listed as 64kb but is 16kb (ecc) starting at 0x2000 0000 and 80kb(not ecc) starting at 0x2000 4000.

    Could anyone provide any assistance on these issues and differences bewteen the sizes and the physical device??
  • Some additional information.
    R7FS3A37A, code flash is 512k in size and broken up into 2k size segments for erasure. For a total of 256 segments.

    Using a J-Link Plus and a combination of J_Flash and J_Mem:

    Attempting to erase the chip/sectors will fail to erase the chip properly with J_Flash. I verify this by connecting to the chip with J_Mem.

    I must one a a time disable the two lowest memory segments in memory then rerun the erase command. I must repeat this until my code flash all reads 0xFF's.
    So, running the erase sectors command (F3) will erase the two lowest selected sectors. It will error as shown below.

    Also, the erasure range listed is incorrect in the second image, 32 sectors of 64k? This does not match my project settings in the third image.

    Once the memory has been erase I can program my mcu.

    The images are in the a word document in the zip.