[ABANDONED] Can't find includes

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] Can't find includes

    I take a nordic example made in SES and import it to other example also done on SES.
    To make it work I take the all includes files and place them in the right order, next to the main example where for the path I use Edit_options-> Preprocessor->User include directories open the window and write them at the right location, towards the project file (see attach). Will some h file found by the SES likenordic_common.h it doesn't find like sdk_common.h where are both in the some folder (see attach), but I look for it from a c file in the some folder (I don't know if it make any diffrent.
    I also notice that in the Edit Options -> Preprocessor -> User include... there is also Inherits use. I don't know when I need to place the include in the Inherits and when in the User include Directories on its line.
    Is there any guide show how to include files?
    Thankls
    Bar.
    Images
    • include path.png

      37.71 kB, 812×1,054, viewed 201 times
    • location.png

      112.05 kB, 812×1,054, viewed 158 times
  • I make some search and found that discussion devzone.nordicsemi.com/f/nordi…in-segger-embedded-studio
    I see that I didn't point to the common so I point to and copy all the include path to this window (see attach) . The first 3 with $(ProjectDir) was before so I didn't touch them .
    Now I look on the project setting window and I see this
    c_user_include_directories="$(ProjectDir)/DeviceSupport;$(ProjectDir)/CoreSupport;$(ProjectDir)/../../../Inc;../../../../../nRF5_SDK_15.2.0_9412b96/components				 ect ect ect
    Why it print now &#x9 instead of the path. I was thinking it is editor format so I copy from a good example but get the some.
    Any idea how I fix it?
    Bar.
    Images
    • user include dir in common setting.png

      34.87 kB, 812×1,054, viewed 149 times