[SOLVED] JLinkArm_SDK.dll ConfigureJTags not working from C#

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JLinkArm_SDK.dll ConfigureJTags not working from C#

    I have a python script that flashes the memory on a device we have. It's an RX63N, or rather 2 RX63Ns. It has 2 microprocessors, called A and B. To configure A, the python script calls -snip-. For B, it uses the same function with (0,0).
    I want the functionality available to a C# library I'm working on without calling out to Python, so I've ported the script to C#, and it works, but the strange thing is that I can't access Micro A. I can flash B successfully, but A continues to fail. My code to import the function follows:


    I don't get an error code, and I can see ConfigTags getting called in the control panel. As far as I can tell, I'm passing the right values, but they seem to be getting mangled and I end up back at the default of (0,0). In fact, any values I pass (from 0 to 64 inclusive) all get routed back to B.
    I suspect that I'm marshalling IRPre and DRPre (params 1 and 2, respectively) incorrectly, but I can't figure out how- they're longs according to the docs. Anyone have any ideas?
  • Hello,

    Thank you for your inquiry.
    Please understand that discussion J-Link SDK content in a public forum is against the license terms.
    If you are still under valid support period feel free to open a support ticket. More information can be found in my signature.

    This thread will be closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.