[SOLVED] RTT viewer command line

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] RTT viewer command line


    I am trying to start using command line options like this:

    "C:\Program Files (x86)\SEGGER\JLink_V640\JLinkRTTViewer.exe" –autoconnect -serialnumber 1111111111

    serial number is of course the right one

    my problem is that dialog box appears even when it is suppressed by autoconnect
    when I confirm by OK, another dialog appears with serial number selection, after that last warning message appears as shown here bellow

    how can I connect directly without dialogs?
    • 1.png

      32.11 kB, 637×691, viewed 620 times
    • 2.png

      9.89 kB, 424×218, viewed 276 times
  • Hello rum,

    Thank you for your inquiry.
    Sorry for the delay in response.

    Currently, the command line parameters for the J-Link RTT Viewer support the use of one dash for the abbreviated version of a command line option (e.g. -a for autoconnect)
    as well as the use of two dashes for the written-out option (e.g. --autoconnect for autoconnect).

    Could you please try the following command line?

    "C:\Program Files (x86)\SEGGER\JLink_V640\JLinkRTTViewer.exe" -–autoconnect --serialnumber <YourSerialNumber>
    Best regards,
  • Hello Leon,

    I already figured out from manual that I have to use "two dashes" version, so in my case

    "C:\Program Files (x86)\SEGGER\JLink_V640\JLinkRTTViewer.exe" -–autoconnect --serialnumber <my serial> -–connection sess

    (because I use also debugger), I see now that serial number is populated...

    but still I cannot get passed dialog window

    additional info: I have two jlinks attached on usb

    thanks for help

  • Hello rum,

    Sorry for the delay in response.
    I tried reproducing the error you are facing, with no success. The setup you described worked on my end:

    - Connect to J-Link via J-Link commander (you are using a debugger)
    - Start JLinkRTTViewer with "--autoconnect --serialnumber <S/N> --connection sess"

    --> JLinkRTTViewer starts without any additional dialog and attaches to J-Link using the existing session

    I cannot get passed dialog window
    Exactly which dialog are you referring to?
    a) The Configuration dialog (seen in the 1.png of your initial post)
    b) The "script file not found" dialog (seen in the 2.png of your initial post)
    c) A different dialog?

    Either way, could you please attach a screenshot of the said dialog window to your response?

    Thank you.
    Best regards,
  • Hello Leon,

    this dialog in attachment… I thing that when "autoconnect" option is used it should no appear?

    before I had on line "script file" = unspecified (which is default setting), as seen in previous post. When you hit OK, appeared warning "scrip not found".
    This is not occurring anymore since I deleted "unspecified".

    • S.JPG

      42.05 kB, 382×445, viewed 271 times
  • Hello Leon,

    it is posted on 25/1. here it is again

    "C:\Program Files (x86)\SEGGER\JLink_V642\JLinkRTTViewer.exe" -–autoconnect --serialnumber <my serial> -–connection sess

    if you missed, I am also using two jlinks.

    thanks for helping, it is really only a small issue

  • Hello rum,

    I asked for a screenshot to ensure that there are no typos or similar in the command line, but I can exclude this now.
    I know you are using multiple J-Links, thank you for the heads-up.
    We highly appreciate you using our products.

    I managed to reproduce the issue you are facing and am currently trying to pinpoint the exact issue.
    As soon as I have a fix or work-around ready, I will get back to you. I expect to find and resolve the problem tomorrow.

    Thank you for your patience.
    Best regards,
  • Hello rum,

    In the command line that you posted, you are using a different symbol than an ASCII minus.
    If you look closely:

    You can see that those symbols are different, which is why they were parsed incorrectly.
    Could you please make sure to only use the standard ASCII minus symbol (0x2D) for command line parameters?

    Here is a corrected version of your command line:
    "C:\Program Files (x86)\SEGGER\JLink_V642\JLinkRTTViewer.exe" --autoconnect --serialnumber <S/N> --connection sess

    Could you please try again with the corrected version and provide feedback?
    Thank you in advance.
    Best regards,