[ABANDONED] connect failed. Failed to connect to target. No idcode detected.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] connect failed. Failed to connect to target. No idcode detected.

    I am facing the issue while trying to run code from SES.
    PCA10056 board, nRF52840, no change to the board.
    Agilent / Keysight DC Power Analyzer N6705B
    SES for ARM v4.12
    Segger JLink v6.40
    S140 SoftDevice s140_nrf52_6.1.0_softdevice / s140_nrf52_6.1.1_softdevice

    For the power analysis using DC Power Analyzer, I was using examples from nRF5_SDK_15.2.0_9412b96.
    I had copied via windows USB drive JLink, components\softdevice\s140\hex\s140_nrf52_6.1.0_softdevice or DeviceDownload\s140nrf52611\s140_nrf52_6.1.1_softdevice.
    It was successful.
    Edited the project ble_app_pwr_profiling_pca10056_s140 in ble_peripheral\ble_app_pwr_profiling\ to make the advertising at 1 sec intervals.
    It worked for a while. I was able to detect and connect from the nRF Connect Android app.

    After some testing and trials and all, now not able to flash from the SES.

    Error is:

    Source Code

    1. Connecting ‘J-Link’ using ‘USB’
    2. Connecting to target using SWD
    3. Loaded C:/Program Files/SEGGER/SEGGER Embedded Studio for ARM 4.12/bin/JLink_x64.dll
    4. Firmware Version: J-Link OB-SAM3U128-V2-NordicSemi compiled Jul 12 2018 11:44:41
    5. DLL Version: 6.40`
    6. Hardware Version: V1.00
    7. Target Voltage: 3.300
    8. Device "NRF52840_XXAA" selected.
    9. connect failed
    10. Failed to connect to target.
    11. No idcode detected.
    12. Please check connection and Target Interface Type
    Display All

    Tried using J-Flash, to connect, erase chip... and the error log:

    Source Code

    1. Application log started
    2. - J-Flash V6.40 (J-Flash compiled Oct 26 2018 15:06:20)
    3. - JLinkARM.dll V6.40 (DLL compiled Oct 26 2018 15:06:02)
    4. Opening project file [C:\Users\pkrishna\20190110.jflash] ...
    5. - Project opened successfully
    6. Failed to open data file [C:\Users\pkrishna\]...
    7. Connecting ...
    8. - Connecting via USB to J-Link device 0
    9. - J-Link firmware: J-Link OB-SAM3U128-V2-NordicSemi compiled Jul 12 2018 11:44:41
    10. - Device "NRF52840_XXAA" selected.
    11. - Target interface speed: 200 kHz (Auto)
    12. - VTarget = 3.300V
    13. - ERROR: Failed to connect.
    14. Could not establish a connection to target.
    15. J-Link firmware: J-Link OB-SAM3U128-V2-NordicSemi compiled Jul 12 2018 11:44:41
    16. Erasing chip ...
    17. - Connecting ...
    18. - Device "NRF52840_XXAA" selected.
    19. - Target interface speed: 200 kHz (Auto)
    20. - VTarget = 3.300V
    21. - ERROR: Failed to connect.
    22. Could not establish a connection to target.
    23. - ERROR: Could not erase chip, not connected
    24. Close project
    25. - Project closed
    Display All

    And JFlash-Lite

    Source Code

    1. Connecting to J-Link...
    2. Connecting to target...
    3. ERROR: Could not connect to target.
    4. Done

    Also, nrfjprog with options to erase chip,
    In that case, it's always same error: JLinkARM.dll CORESIGHT_WriteAPDPReg returned error -1. JLinkARM.dll CORESIGHT_WriteAPDPReg returned error -102.

    attached the log.

    As of now,
    though not able to connect from SES debugger, but able to detect the USB drive JLink in windows when connected. Then, by copying hex, not able detect using Android app.
    Only nRF Connect Android app is able to detect & connect.
    may be, even though JLink drive disappears and appears back in Windows, does not mean flashing successful ? There is no ERROR log file inside the JLink drive !

    What should I do to bring it up !? Please guide me.

    Thanks in advance !
    • log04-e.log

      (224.37 kB, downloaded 64 times, last: )
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us. Connect to all our nRF boards is working without any issues.
    Could you post a screenshot of a J-Link Commander connect session?
    Do you have an external J-Link to use for testing? It might be that the J-Link OB was damaged in some way.
    Does connecting work with another "fresh" eval board?
    Could you provide a J-Link log of the failed session?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.