[SOLVED] Getting Started with Flasher ATE on STM8 Devices

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Getting Started with Flasher ATE on STM8 Devices

    Hello all,
    I'm working on a project involving the Flasher ATE for a production flasher. I have been reading through the documentation (UM08035) to figure out how this thing works but I am having trouble getting it to work.

    The device I am trying to flash is a STM8 microcontroller. I configured the IP address of the ATE and connected to it using telnet (using putty) and an FTP client. That all works as expected. I downloaded the Universal Flash Loader Configurator and loaded the hex file to flash. I have configured the configurator for the chip I have to program and configured the different bits (ERASE, PROGRAM, VERIFY, etc). I generated the UNI file, the DAT file, and clicked on Generate Test Data file... (which generated an MOT file). I loaded the files into the ATE module (only one for now) using FTP in the .MODULE1 folder. I'm not using serialization or patching. However, I cannot find where to generate the .cfg file or .pex file that the manual talks about on page 31. I did find STM8AS.pex that is referenced for my chip in the ST_STM8.xml in the UniversalFlashLoader folder. Is this the .pex file I need? How do I generate the .cfg file? I downloaded Flasher STM8, made a new project using the chip I have, set the same project settings as the universal loader configurator and hit "Save Programmer Configuration File..." which did produce a .cfg file.

    I put those on my ATE module 1 folder like such:

    Also, when I go to manually power on the board through either the USB or VTGT power, I get nothing on pin 19. I have tried #POWERON 1 0,0 and #POWERON 1 1,0. I have verified the USB and VTGT voltages are both right at 5V. I have tried setting the Vref to 5000 using #SETVTREF 1 5000. What am I doing wrong?

    Here are my current connections:
    Target ATE
    5V 19
    GND 4
    SWIM 9
    RESET 15

    I am having trouble setting up the flasher ATE using the universal flash configurator. I am also having issue with the #POWERON command not putting power to the board.

    Please can you help me?

      (58 Byte, downloaded 9 times, last: )

      (60 Byte, downloaded 10 times, last: )
  • I wanted to move past the POWERON issue for now and decided to just apply power to the board externally. When I did that I found out I had to have 5V also going to Pin 1 for target voltage reporting. After doing that I got this error from the log:

    ERROR: Cannot connect to CPU. Target interface speed too high?
    SN: 0 - Failed

    Changing HighSpeed = "0" did not fix it either.

    Here are my connections:

    5V -> Target Board Power In, ATE Pin 1, ATE VTGT + and Ext Power +
    GND -> Target Board GND, ATE Pin 4, ATE VTGT - and Ext Power -
    SWIM -> ATE Pin 9
    RESET -> ATE Pin 15

    These boards are pre-programmed and tested production boards.

    Any thoughts?


      (372 Byte, downloaded 8 times, last: )
  • Hello,

    We received your inquiry via support ticket as well.
    This thread will be closed now so no information gets lost between different communication channels.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/