[SOLVED] VCS integration with GIT error

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] VCS integration with GIT error

    I have issues using VCS on macos with GIT. I have local repository (cloned from the server), which I can open with GIT client (Tower).
    In Embedded studio, I have configured the git executable "/usr/bin/git" and preferred username and email. When I load the project, I get "dirty file" notification that I need to commit changes. I have set the git login for the project (it is correct one as I am using the same from Tower), but when I try to commit the changes I get error:

    "Commit post-multi failed; Git login returned"

    Any idea what is that about, and how to fix it ?

    Edit: Funny thing, when I removed the login info from VCS, commit worked.

    Version is 3.34b Build 2018042302.35806
    macOS x64

    The post was edited 1 time, last by Gossamer: found workaround ().

  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us.
    How did you set up VCS in Embedded Studio?
    Did you follow this guide? wiki.segger.com/SEGGER_Embedded_Studio#VCS_configuration

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/