[SOLVED] Error programming ATSAME51J20 with Atmel Studio

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Error programming ATSAME51J20 with Atmel Studio

    I have opened a support ticket on this, but I am posting this here in case anyone else has this problem.

    J-Link v6.40

    The initial attempt to debug a program on a new board failed with a misleading error: Failed to set gdb proxy.

    Using Tools > Device Programming shows that the chip can be erased, but not programmed, verify fails.

    The work around for now is to use the J-Link Control Panel and override the device selection to ATSAME51J19. Programming will then work correctly.
  • Hello,

    Thank you for your inquiry.
    This sounds more like an issue that Atmel Studio is passing the wrong target device name.
    J-Link has to know exactly which target device it is connecting to.
    For further information and setup questions we suggest getting in contact with Atmel.
    From J-Link perspective everything is working fine as elaborated in the references Support Ticket.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/