[SOLVED] TMS570LS0432/JLink Mini EDU: IDCODE mismatch

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] TMS570LS0432/JLink Mini EDU: IDCODE mismatch


    I am having some issues programming a TI TMS570LS0432 with a JLink Mini EDU. The MCU is on a custom board, which doesn't have any obvious design flaws that I know of. I'm fairly certain that I have the debugger attached properly to the micro, but I am receiving this error message upon attempting to connect:

    My voltage reference is 3.3V (actual value in this situation was somewhere around 3.298V, which I'm guessing is close enough). I've seen other threads where users have said that this exact error is caused by bad connections. However, I'm fairly confident that all the connections are good (the only way they could be better is if I soldered the wires from the debugger directly to the header). Does anyone know some more specifics on what exactly is happening here? Google hasn't been a huge help with any of these error codes.

    Thank you for your time,
    Thomas Meier
  • Hello,

    Thank you for your inquiry.
    The J-Link Edu Mini supports Cortex-M targets only: segger.com/products/debug-prob…k/models/j-link-edu-mini/
    The TMS570LS is a Cortex-R4.
    We will see if the error messages can be improved so it gets more clear if a core is not supported.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/