[SOLVED] JLink/JMEM/MK66F18 - unable to read peripheral registers

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JLink/JMEM/MK66F18 - unable to read peripheral registers

    Using JMEM on an MK66FN2M0VM018 (FRDM-K66F) I am able to read Flash content (0x00000000), SRAM space (0x20000000, 0x1FFF0000) and Cortex-M space (0xE00000000). But on any attempt to read 0x40000000 space a ding rings and dashes shown.

    While it is understood unclocked peripherals can't be read this should not be the case for the SIM (0x40048000) or MCG (0x40064000).

    Workalot is wondering why.
  • Hello,

    Thank you for your inquiry.
    The AIPS registers starting at 0x40... have many gaps in between (See AIPS-Lite section in K66 manual). Trying to read the gaps will result in an error.
    If you execute mem32 0x40000000 1 in J-Link Commander you should be able to read the AIPS0_MPRA.
    JMem can't be used for reading memory with gaps as JMem will try to read the whole memory block you are currently looking at.
    On the K66 this will result in failure.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/