[SOLVED] Can not use J-link EDU or mini in JTAG mode

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Can not use J-link EDU or mini in JTAG mode

    I am able to program my NXP K66 with an older J-link KS, but when I go to program it with a new J-link EDU (or mini) I get an InitTarget(): PCode returned with error code -1. There are some "connect under reset" messages in there too.

    Any Idea whats going on? Both programmers work in SWD mode, and I know my pinout/hardware is good because the j-link ks works... what am I missing with these new programmers?

    FYI I know the device isn't locked, and I have tried a lower speed.
    • J-link_EDU.png

      49.34 kB, 979×1,053, viewed 139 times
    • J-link_KS.png

      73.95 kB, 702×975, viewed 88 times
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us.
    Could you try updating to the latest J-Link Software version and report back if the issue persists?
    Are you using the original JTAG cable shipped with the J-Link Edu?
    We had many cases where third party cables were the cause of signal issues.
    Could you measure the JTAG signals at target device side with an oscilloscope and post pictures of your measurements?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.