[SOLVED] Missing processor number during build

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Missing processor number during build

    Release 4.10a Build 2018110203.37618
    Windows x64

    Minor issue - during compilation, in the output pane, it used to show the core number being used for that command i.e. in the list below, at the start of the line instead of "1>" I would see "1>" or "2>" or "3>" or "4>" depending on which core was being used for the compilation/assembly. I no longer see that. Instead, I only see the "1>". Sample output is copied below. I deleted portions that had my path or extraneous stuff that didn't add value.

    Build->Parallel and Unity Builds->Building Threads is set to 8 and Disable Unity Build is not checked.

    I did run Task Manager and it shows all four cores with the same usage profile. So, presumably, all cores are being used.

    If I disable Parallel and Unity Build, it has no affect on the Task Manager core usage. Build->Parallel and Unity Build->Disable Unity Build checked.

    Sample output:

    1> Compiling ‘system_stm32f4xx.c’
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/cc1" <STUFF DELETED>
    1> In file included from Drivers/CMSIS/Device/ST/STM32F4xx/Include/stm32f4xx.h:171:0,
    1> from <STUFF DELETED>
    1> Drivers/CMSIS/Device/ST/STM32F4xx/Include/stm32f411xe.h:68:0: warning: "__FPU_PRESENT" redefined
    1> <command-line>:0:0: note: this is the location of the previous definition
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/as" <STUFF DELETED>
    1> rm <STUFF DELETED>
    1> Compiling ‘SEGGER_RTT.c’
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/cc1" <STUFF DELETED>
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/as" <STUFF DELETED>
    1> rm <STUFF DELETED>
    1> Compiling ‘SEGGER_RTT_SES.c’
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/cc1" <STUFF DELETED>
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/as" <STUFF DELETED>
    1> Assembling ‘thumb_crt0.s’
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/cc1" <STUFF DELETED>
    1> "C:/Program Files/SEGGER/EmbeddedStudio/gcc/arm-none-eabi/bin/as" <STUFF DELETED>
    1> rm <STUFF DELETED>


    -------------------->8-------------------8<--------------------

    Another item - please consider adding a feature to the Help->About dialog box to copy relevant version info. This way, we can click that and paste it into reports and you will have a common format for those that actually use it...

    Thanks!
    Harjit
  • Hello Harjit,

    Thank you for your inquiry.
    Could you check your settings under Tool->Options->Building->Parallel Project Building
    This setting should be set to No.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.
  • Hello,

    Great to hear that you are up and running again.

    This thread will be closed now.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.